Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pyesasky
  4. ›
  5. CVE-2022-30885

CVE-2022-30885: Inclusion of Functionality from Untrusted Control Sphere (Malicious Dependency)

June 24, 2022 (updated October 28, 2022)

The pyesasky for python, as distributed on PyPI, included a code-execution backdoor inserted by a third party. The current version, without this backdoor, is 1.2.0-1.4.2.

References

  • pypi.doubanio.com/simple/request
  • github.com/esdc-esac-esa-int/pyesasky/issues/39
  • nvd.nist.gov/vuln/detail/CVE-2022-30885
  • pypi.org/project/pyesasky/

Code Behaviors & Features

Detect and mitigate CVE-2022-30885 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.2.0 up to 1.4.2

Fixed versions

  • 1.4.3

Solution

Upgrade to version 1.4.3 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

pypi/pyesasky/CVE-2022-30885.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:54 +0000.