Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pycryptodome
  4. ›
  5. CVE-2018-15560

CVE-2018-15560: PyCryptodome integer overflow vulnerability

August 27, 2018 (updated October 21, 2024)

PyCryptodome before 3.6.6 has an integer overflow in the data_len variable in AESNI.c, related to the AESNI_encrypt and AESNI_decrypt functions, leading to the mishandling of messages shorter than 16 bytes.

References

  • github.com/Legrandin/pycryptodome
  • github.com/Legrandin/pycryptodome/issues/198
  • github.com/advisories/GHSA-hgg3-g7gr-66r7
  • github.com/pypa/advisory-database/tree/main/vulns/pycryptodome/PYSEC-2018-21.yaml
  • nvd.nist.gov/vuln/detail/CVE-2018-15560
  • whitehatck01.blogspot.com/2018/08/integer-overflow-vulnerability-in.html

Code Behaviors & Features

Detect and mitigate CVE-2018-15560 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.6.6

Fixed versions

  • 3.6.6

Solution

Upgrade to version 3.6.6 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-190: Integer Overflow or Wraparound

Source file

pypi/pycryptodome/CVE-2018-15560.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:27 +0000.