Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. proxy.py
  4. ›
  5. CVE-2021-3116

CVE-2021-3116: Logic error in authentication in proxy.py

April 7, 2021 (updated October 21, 2024)

before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data because of a boolean confusion (and versus or).

References

  • cardaci.xyz/advisories/2021/01/10/proxy.py-2.3.0-broken-basic-authentication
  • github.com/abhinavsingh/proxy.py
  • github.com/abhinavsingh/proxy.py/commit/bff171ec26d826ae1d22d2466eaf9d8bdbf059d3
  • github.com/abhinavsingh/proxy.py/pull/482
  • github.com/abhinavsingh/proxy.py/pull/482/commits/9b00093288237f5073c403f2c4f62acfdfa8ed46
  • github.com/advisories/GHSA-cmc7-mfmr-xqrx
  • github.com/pypa/advisory-database/tree/main/vulns/proxy-py/PYSEC-2021-46.yaml
  • nvd.nist.gov/vuln/detail/CVE-2021-3116
  • pypi.org/project/proxy.py/2.3.1/

Code Behaviors & Features

Detect and mitigate CVE-2021-3116 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.1

Fixed versions

  • 2.3.1

Solution

Upgrade to version 2.3.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication
  • CWE-480: Use of Incorrect Operator
  • CWE-697: Incorrect Comparison

Source file

pypi/proxy.py/CVE-2021-3116.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.