Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. privacyIDEA
  4. ›
  5. CVE-2018-1000809

CVE-2018-1000809: privacyIDEA Improper Input Validation vulnerability

January 14, 2019 (updated October 18, 2024)

privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability in token validation api that can result in Denial-of-Service. This attack appear to be exploitable via http request with user=&pass= to /validate/check url. This vulnerability appears to have been fixed in 2.23.2.

References

  • github.com/advisories/GHSA-7qqv-r2q4-jxhm
  • github.com/privacyidea/privacyidea
  • github.com/privacyidea/privacyidea/commit/a3edc09beffa2104f357fe24971ea3211ce40751
  • github.com/privacyidea/privacyidea/issues/1227
  • github.com/pypa/advisory-database/tree/main/vulns/privacyidea/PYSEC-2018-20.yaml
  • nvd.nist.gov/vuln/detail/CVE-2018-1000809

Code Behaviors & Features

Detect and mitigate CVE-2018-1000809 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.23.2

Fixed versions

  • 2.23.2

Solution

Upgrade to version 2.23.2 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/privacyIDEA/CVE-2018-1000809.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:59 +0000.