Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pretix
  4. ›
  5. CVE-2023-27891

CVE-2023-27891: Insufficient Session Expiration in pretix

March 7, 2023 (updated October 21, 2024)

rami.io pretix before 4.17.1 allows OAuth application authorization from a logged-out session. The fixed versions are 4.15.1, 4.16.1, and 4.17.1.

References

  • github.com/advisories/GHSA-r76w-3wwq-jv6v
  • github.com/pypa/advisory-database/tree/main/vulns/pretix/PYSEC-2023-42.yaml
  • github.com/thufschmitt/pretix-nix
  • nvd.nist.gov/vuln/detail/CVE-2023-27891
  • pretix.eu/about/en/blog/20230306-release-4171

Code Behaviors & Features

Detect and mitigate CVE-2023-27891 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.15.1, all versions starting from 4.16.0 before 4.16.1, all versions starting from 4.17.0 before 4.17.1

Fixed versions

  • 4.17.1
  • 4.16.1
  • 4.15.1

Solution

Upgrade to versions 4.15.1, 4.16.1, 4.17.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

pypi/pretix/CVE-2023-27891.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.