Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. postfix-mta-sts-resolver
  4. ›
  5. CVE-2019-16791

CVE-2019-16791: postfix-mta-sts-resolver Algorithm Downgrade vulnerability

July 5, 2019 (updated October 21, 2024)

All users of versions prior to 0.5.1 can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

References

  • gist.github.com/Snawoot/b9da85d6b26dea5460673b29df1adc6b
  • github.com/Snawoot/postfix-mta-sts-resolver
  • github.com/Snawoot/postfix-mta-sts-resolver/security/advisories/GHSA-h92m-42h4-82f6
  • github.com/advisories/GHSA-h92m-42h4-82f6
  • github.com/pypa/advisory-database/tree/main/vulns/postfix-mta-sts-resolver/PYSEC-2020-174.yaml
  • nvd.nist.gov/vuln/detail/CVE-2019-16791

Code Behaviors & Features

Detect and mitigate CVE-2019-16791 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.5.1

Fixed versions

  • 0.5.1

Solution

Upgrade to version 0.5.1 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-757: Selection of Less-Secure Algorithm During Negotiation ('Algorithm Downgrade')

Source file

pypi/postfix-mta-sts-resolver/CVE-2019-16791.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:33 +0000.