Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. plotai
  4. ›
  5. CVE-2025-1497

CVE-2025-1497: PlotAI eval vulnerability

March 10, 2025 (updated October 3, 2025)

A vulnerability, that could result in Remote Code Execution (RCE), has been found in PlotAI. Lack of validation of LLM-generated output allows attacker to execute arbitrary Python code. PlotAI commented out vulnerable line, further usage of the software requires uncommenting it and thus accepting the risk.

References

  • cert.pl/en/posts/2025/03/CVE-2025-1497
  • cert.pl/posts/2025/03/CVE-2025-1497
  • github.com/advisories/GHSA-2hmp-5wqg-f24h
  • github.com/mljar/plotai
  • github.com/mljar/plotai/commit/bdcfb13484f0b85703a4c1ddfd71cb21840e7fde
  • github.com/pypa/advisory-database/tree/main/vulns/plotai/PYSEC-2025-22.yaml
  • nvd.nist.gov/vuln/detail/CVE-2025-1497

Code Behaviors & Features

Detect and mitigate CVE-2025-1497 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.7

Fixed versions

  • 0.0.7

Solution

Upgrade to version 0.0.7 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')
  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/plotai/CVE-2025-1497.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:32 +0000.