Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Plone
  4. ›
  5. CVE-2024-0669

CVE-2024-0669: Improper Restriction of Rendered UI Layers or Frames

January 18, 2024 (updated January 19, 2024)

A Cross-Frame Scripting vulnerability has been found on Plone CMS affecting verssion below 6.0.5. An attacker could store a malicious URL to be opened by an administrator and execute a malicios iframe element.

References

  • github.com/advisories/GHSA-5xfx-55x4-j223
  • nvd.nist.gov/vuln/detail/CVE-2024-0669
  • www.incibe.es/en/incibe-cert/notices/aviso/cross-frame-scripting-xfs-plone-cms

Code Behaviors & Features

Detect and mitigate CVE-2024-0669 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 6.0.5

Fixed versions

  • 6.0.7

Solution

Upgrade to version 6.0.7 or above.

Impact 7.1 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-1021: Improper Restriction of Rendered UI Layers or Frames

Source file

pypi/Plone/CVE-2024-0669.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:13 +0000.