Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Plone
  4. ›
  5. CVE-2016-4041

CVE-2016-4041: Plone vulnerable to privilege escalation in WebDAV

May 17, 2022 (updated October 18, 2024)

Plone 4.0 through 5.1a1 does not have security declarations for Dexterity content-related WebDAV requests, which allows remote attackers to gain webdav access via unspecified vectors.

References

  • github.com/advisories/GHSA-qqgj-22gr-73vx
  • github.com/plone/Plone
  • github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2017-55.yaml
  • nvd.nist.gov/vuln/detail/CVE-2016-4041
  • plone.org/security/hotfix/20160419/privilege-escalation-in-webdav

Code Behaviors & Features

Detect and mitigate CVE-2016-4041 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.1a1 before 5.1a2, version 5.1a1, all versions starting from 3.3 before 4.3.10, all versions starting from 5.0 before 5.0.5

Fixed versions

  • 4.3.10
  • 5.0.5
  • 5.1a2

Solution

Upgrade to versions 4.3.10, 5.0.5, 5.1a2 or above.

Impact 7.3 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Source file

pypi/Plone/CVE-2016-4041.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:58 +0000.