Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Plone
  4. ›
  5. CVE-2012-5494

CVE-2012-5494: Plone Cross-site scripting Vulnerability

May 17, 2022 (updated October 9, 2024)

Cross-site scripting (XSS) vulnerability in python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, related to “{u,}translate.”

References

  • github.com/advisories/GHSA-3g6w-4m7x-97v6
  • github.com/plone/Plone
  • github.com/plone/Products.CMFPlone/blob/4.2.3/docs/CHANGES.txt
  • github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2014-36.yaml
  • nvd.nist.gov/vuln/detail/CVE-2012-5494
  • plone.org/products/plone-hotfix/releases/20121106
  • plone.org/products/plone/security/advisories/20121106/10

Code Behaviors & Features

Detect and mitigate CVE-2012-5494 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.3a0 before 4.3b1, all versions before 4.2.3

Fixed versions

  • 4.2.3
  • 4.3b1

Solution

Upgrade to versions 4.2.3, 4.3b1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/Plone/CVE-2012-5494.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:49 +0000.