Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Pillow
  4. ›
  5. CVE-2022-45198

CVE-2022-45198: Pillow vulnerable to Data Amplification attack.

November 14, 2022 (updated October 11, 2024)

Pillow before 9.2.0 performs Improper Handling of Highly Compressed GIF Data (Data Amplification).

References

  • bugs.gentoo.org/855683
  • cwe.mitre.org/data/definitions/409.html
  • github.com/advisories/GHSA-m2vv-5vj5-2hm7
  • github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2022-42979.yaml
  • github.com/python-pillow/Pillow
  • github.com/python-pillow/Pillow/commit/11918eac0628ec8ac0812670d9838361ead2d6a4
  • github.com/python-pillow/Pillow/pull/6402
  • github.com/python-pillow/Pillow/pull/6402/commits/c9f1b35e981075110a23487a8d4a6cbb59a588ea
  • github.com/python-pillow/Pillow/releases/tag/9.2.0
  • nvd.nist.gov/vuln/detail/CVE-2022-45198
  • security.gentoo.org/glsa/202211-10

Code Behaviors & Features

Detect and mitigate CVE-2022-45198 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.2.0

Fixed versions

  • 9.2.0

Solution

Upgrade to version 9.2.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-409: Improper Handling of Highly Compressed Data (Data Amplification)

Source file

pypi/Pillow/CVE-2022-45198.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:51 +0000.