Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Pillow
  4. ›
  5. CVE-2014-3598

CVE-2014-3598: Pillow is vulnerable to Denial of Service (DOS) in the Jpeg2KImagePlugin

May 14, 2022 (updated October 9, 2024)

The Jpeg2KImagePlugin plugin in Pillow before 2.5.3 allows remote attackers to cause a denial of service via a crafted image.

References

  • github.com/advisories/GHSA-j6f7-g425-4gmx
  • github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2015-15.yaml
  • github.com/python-pillow/Pillow
  • github.com/python-pillow/Pillow/commit/347a1d8d956f9e64af4463ee25311b60cdd5657d
  • nvd.nist.gov/vuln/detail/CVE-2014-3598
  • pypi.python.org/pypi/Pillow/2.5.3

Code Behaviors & Features

Detect and mitigate CVE-2014-3598 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.5.3

Fixed versions

  • 2.5.3

Solution

Upgrade to version 2.5.3 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Source file

pypi/Pillow/CVE-2014-3598.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:40 +0000.