Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pgadmin4
  4. ›
  5. CVE-2025-12765

CVE-2025-12765: pgAdmin has vulnerability in LDAP authentication mechanism that allows bypassing TLS certificate verification

November 13, 2025

pgAdmin <= 9.9 is affected by a vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification.

References

  • github.com/advisories/GHSA-g4r8-3qmh-pmch
  • github.com/pgadmin-org/pgadmin4
  • github.com/pgadmin-org/pgadmin4/commit/09d2b7eeb0e330df73b1aef0cba57788fde52b6b
  • github.com/pgadmin-org/pgadmin4/issues/9324
  • nvd.nist.gov/vuln/detail/CVE-2025-12765

Code Behaviors & Features

Detect and mitigate CVE-2025-12765 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.10

Fixed versions

  • 9.10

Solution

Upgrade to version 9.10 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

pypi/pgadmin4/CVE-2025-12765.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.