Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pgadmin4
  4. ›
  5. CVE-2025-12762

CVE-2025-12762: pgAdmin4 vulnerable to Remote Code Execution (RCE) when running in server mode

November 13, 2025

pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.

References

  • github.com/advisories/GHSA-w2p4-p4rh-qcm3
  • github.com/pgadmin-org/pgadmin4
  • github.com/pgadmin-org/pgadmin4/commit/1d397395f75320ca1d4ed5e9ca721c603415e836
  • github.com/pgadmin-org/pgadmin4/issues/9320
  • nvd.nist.gov/vuln/detail/CVE-2025-12762

Code Behaviors & Features

Detect and mitigate CVE-2025-12762 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.10

Fixed versions

  • 9.10

Solution

Upgrade to version 9.10 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/pgadmin4/CVE-2025-12762.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.