Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pgadmin4
  4. ›
  5. CVE-2024-3116

CVE-2024-3116: pgAdmin Remote Code Execution (RCE) vulnerability

April 4, 2024 (updated February 11, 2025)

pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system’s integrity and the security of the underlying data.

References

  • gist.github.com/aelmokhtar/689a8be7e3bd535ec01992d8ec7b2b98
  • github.com/advisories/GHSA-27jx-ffw8-xrqv
  • github.com/pgadmin-org/pgadmin4
  • github.com/pgadmin-org/pgadmin4/commit/fbbbfe22dd468bcfef1e1f833ec32289a6e56a8b
  • github.com/pgadmin-org/pgadmin4/issues/7326
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2
  • nvd.nist.gov/vuln/detail/CVE-2024-3116
  • www.vicarius.io/vsociety/posts/remote-code-execution-vulnerability-in-pgadmin-cve-2024-3116

Code Behaviors & Features

Detect and mitigate CVE-2024-3116 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 8.5

Fixed versions

  • 8.5

Solution

Upgrade to version 8.5 or above.

Impact 7.4 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

Learn more about CVSS

Source file

pypi/pgadmin4/CVE-2024-3116.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:09 +0000.