Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. paddlepaddle
  4. ›
  5. CVE-2023-52306

CVE-2023-52306: PaddlePaddle floating point exception in paddle.lerp

January 3, 2024 (updated November 22, 2024)

FPE in paddle.lerpĀ in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.

References

  • github.com/PaddlePaddle/Paddle
  • github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2023-015.md
  • github.com/PaddlePaddle/Paddle/commit/19da5c0c4d8c5e4dfef2a92e24141c3f51884dcc
  • github.com/advisories/GHSA-rg9q-m8hv-xxr6
  • github.com/pypa/advisory-database/tree/main/vulns/paddlepaddle/PYSEC-2024-138.yaml
  • nvd.nist.gov/vuln/detail/CVE-2023-52306

Code Behaviors & Features

Detect and mitigate CVE-2023-52306 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.0

Fixed versions

  • 2.6.0

Solution

Upgrade to version 2.6.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-369: Divide By Zero

Source file

pypi/paddlepaddle/CVE-2023-52306.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:49 +0000.