Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. OpenEXR
  4. ›
  5. CVE-2026-27622

CVE-2026-27622: OpenEXR's CompositeDeepScanLine integer-overflow leads to heap OOB write

March 2, 2026 (updated March 4, 2026)

Function: CompositeDeepScanLine::readPixels, reachable from high-level multipart deep read flows (MultiPartInputFile + DeepScanLineInputPart + CompositeDeepScanLine).

Vulnerable lines (src/lib/OpenEXR/ImfCompositeDeepScanLine.cpp):

  • total_sizes[ptr] += counts[j][ptr]; (line ~511)
  • overall_sample_count += total_sizes[ptr]; (line ~514)
  • samples[channel].resize (overall_sample_count); (line ~535)

Impact: 32-bit sample-count accumulation wrap leads to undersized allocation, then decode writes with true sample volume, causing heap OOB write in generic_unpack_deep_pointers (src/lib/OpenEXRCore/unpack.c:1374) (DoS/Crash, memory corruption/RCE).

Attack scenario:

  • Attacker provides multipart deep EXR with many parts and very large sample counts per pixel.
  • Uses compression (RLE/ZIPS) to keep file size relatively small vs decode pressure.
  • The overflow happens in composite sample accounting (unsigned int), while pointer progression for decode uses larger counters and reaches out-of-bounds.

Tested on: OpenEXR 4.0.0-dev (commit 83449669402080874b25ff1fa740649a9e6ea064) but this code has existed since v2.3.0

References

  • github.com/AcademySoftwareFoundation/openexr
  • github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-cr4v-6jm6-4963
  • github.com/advisories/GHSA-cr4v-6jm6-4963
  • nvd.nist.gov/vuln/detail/CVE-2026-27622

Code Behaviors & Features

Detect and mitigate CVE-2026-27622 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.3.0 before 3.2.6, all versions starting from 3.3.0 before 3.3.8, all versions starting from 3.4.0 before 3.4.6

Fixed versions

  • 3.2.6
  • 3.3.8
  • 3.4.6

Solution

Upgrade to versions 3.2.6, 3.3.8, 3.4.6 or above.

Impact 7.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-787: Out-of-bounds Write

Source file

pypi/OpenEXR/CVE-2026-27622.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:35 +0000.