Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. opencv-contrib-python
  4. ›
  5. CVE-2016-1517

CVE-2016-1517: Improper Input Validation

October 12, 2021

OpenCV allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

References

  • arxiv.org/pdf/1701.04739.pdf
  • github.com/advisories/GHSA-fffj-9qwg-qmh5
  • github.com/opencv/opencv/issues/5956
  • github.com/opencv/opencv/pull/9376
  • nvd.nist.gov/vuln/detail/CVE-2016-1517

Code Behaviors & Features

Detect and mitigate CVE-2016-1517 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 3.3.0.10

Fixed versions

  • 3.3.1.11

Solution

Upgrade to version 3.3.1.11 or above.

Impact 5.5 MEDIUM

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/opencv-contrib-python/CVE-2016-1517.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:15 +0000.