Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. OctoPrint
  4. ›
  5. CVE-2022-3068

CVE-2022-3068: OctoPrint Improper Privilege Management vulnerability

September 22, 2022 (updated October 8, 2024)

OctoPrint prior to 1.8.3 allows a user with read access only to access a privileged user’s account and functionality. Version 1.8.3 contains a patch for this issue.

References

  • github.com/advisories/GHSA-2p75-q37p-f852
  • github.com/octoprint/octoprint
  • github.com/octoprint/octoprint/commit/ef95ef1c101b79394f134e8fce000e6bae046571
  • github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2022-283.yaml
  • huntr.dev/bounties/f45c24cb-9104-4c6e-a9e1-5c7e75e83884
  • nvd.nist.gov/vuln/detail/CVE-2022-3068

Code Behaviors & Features

Detect and mitigate CVE-2022-3068 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.8.3

Fixed versions

  • 1.8.3

Solution

Upgrade to version 1.8.3 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

pypi/OctoPrint/CVE-2022-3068.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:33 +0000.