Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. OctoPrint
  4. ›
  5. CVE-2022-1430

CVE-2022-1430: Cross-site Scripting in OctoPrint

May 19, 2022 (updated October 8, 2024)

Cross-site Scripting (XSS) - DOM in GitHub repository octoprint/octoprint prior to 1.8.0. The login endpoint allows for javascript injection which may lead to account takeover in a phishing scenario.

References

  • github.com/advisories/GHSA-x7r7-wmj8-vv5g
  • github.com/octoprint/octoprint
  • github.com/octoprint/octoprint/commit/8087528e4a7ddd15c7d95ff662deb5ef7de90045
  • github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2022-200.yaml
  • huntr.dev/bounties/0cd30d71-1e32-4a0b-b4c3-faaa1907b541
  • nvd.nist.gov/vuln/detail/CVE-2022-1430

Code Behaviors & Features

Detect and mitigate CVE-2022-1430 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.8.0

Fixed versions

  • 1.8.0

Solution

Upgrade to version 1.8.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/OctoPrint/CVE-2022-1430.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:57 +0000.