Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. OctoPrint
  4. ›
  5. CVE-2021-32561

CVE-2021-32561: OctoPrint API Error Messages vulnerable to XSS

May 24, 2022 (updated October 8, 2024)

OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.

References

  • github.com/OctoPrint/OctoPrint
  • github.com/OctoPrint/OctoPrint/releases/tag/1.6.0
  • github.com/advisories/GHSA-vcx4-fpmp-mvv6
  • github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2021-30.yaml
  • nvd.nist.gov/vuln/detail/CVE-2021-32561
  • octoprint.org/blog/2021/04/27/new-release-1.6.0
  • www.brzozowski.io/
  • www.brzozowski.io/web-applications/2021/05/11/the-insecure-story-of-octoprint.html

Code Behaviors & Features

Detect and mitigate CVE-2021-32561 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.0

Fixed versions

  • 1.6.0

Solution

Upgrade to version 1.6.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/OctoPrint/CVE-2021-32561.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:59 +0000.