Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. octavia
  4. ›
  5. CVE-2019-17134

CVE-2019-17134: OpenStack Octavia Amphora-Agent not requiring Client-Certificate

May 24, 2022 (updated May 2, 2024)

Amphora Images in OpenStack Octavia >=0.10.0 <2.1.2, >=3.0.0 <3.2.0, >=4.0.0 <4.1.0 allows anyone with access to the management network to bypass client-certificate based authentication and retrieve information or issue configuration commands via simple HTTP requests to the Agent on port https/9443, because the cmd/agent.py gunicorn cert_reqs option is True but is supposed to be ssl.CERT_REQUIRED.

References

  • github.com/advisories/GHSA-r4v4-3jj7-jc29
  • github.com/openstack/octavia
  • github.com/openstack/octavia/commit/1725517d1d209f26b2275306d83e49c099dcbe1a
  • github.com/openstack/octavia/commit/2976a7f0f109e17930db8a61136526ead44ea7e5
  • github.com/openstack/octavia/commit/624ff08f27bcb73788663cbe6d35cbe29c537844
  • github.com/openstack/octavia/commit/89a2f6e0136ad49d928eb65b4cf555af2a2b8ab1
  • github.com/openstack/octavia/commit/b0c2cd7b4c835c391cfedf12cf9f9ff8a0aabd17
  • github.com/openstack/octavia/commit/c2fdffc3b748f8007c72e52df257e38756923b40
  • nvd.nist.gov/vuln/detail/CVE-2019-17134
  • review.opendev.org/686541
  • review.opendev.org/686543
  • review.opendev.org/686544
  • review.opendev.org/686545
  • review.opendev.org/686546
  • review.opendev.org/686547
  • security.openstack.org/ossa/OSSA-2019-005.html
  • storyboard.openstack.org/

Code Behaviors & Features

Detect and mitigate CVE-2019-17134 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.10.0 before 2.1.2, all versions starting from 3.0.0 before 3.2.0, all versions starting from 4.0.0 before 4.1.0

Fixed versions

  • 2.1.2
  • 3.2.0
  • 4.1.0

Solution

Upgrade to versions 2.1.2, 3.2.0, 4.1.0 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

pypi/octavia/CVE-2019-17134.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:17 +0000.