Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. oauthenticator
  4. ›
  5. CVE-2024-37300

CVE-2024-37300: Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0

June 12, 2024

JupyterHub < 5.0, when used with GlobusOAuthenticator, could be configured to allow all users from a particular institution only. The configuration for this would look like:

References

  • github.com/advisories/GHSA-gprj-3p75-f996
  • github.com/jupyterhub/oauthenticator
  • github.com/jupyterhub/oauthenticator/commit/d1aea05fa89f2beae15ab0fa0b0d071030f79654
  • github.com/jupyterhub/oauthenticator/security/advisories/GHSA-gprj-3p75-f996
  • nvd.nist.gov/vuln/detail/CVE-2024-37300

Code Behaviors & Features

Detect and mitigate CVE-2024-37300 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 16.3.1

Fixed versions

  • 16.3.1

Solution

Upgrade to version 16.3.1 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

pypi/oauthenticator/CVE-2024-37300.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.