Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. nvflare
  4. ›
  5. CVE-2022-31605

CVE-2022-31605: Deserialization of Untrusted Data

July 1, 2022 (updated July 13, 2022)

NVFLARE, versions prior to 2.1.2, contains a vulnerability in its utils module, where YAML files are loaded via yaml.load() instead of yaml.safe_load(). The deserialization of Untrusted Data, may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.

References

  • github.com/NVIDIA/NVFlare/security/advisories/GHSA-hrf3-622q-8366
  • github.com/advisories/GHSA-hrf3-622q-8366
  • nvd.nist.gov/vuln/detail/CVE-2022-31605

Code Behaviors & Features

Detect and mitigate CVE-2022-31605 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.2

Fixed versions

  • 2.1.2

Solution

Upgrade to version 2.1.2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data
  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

pypi/nvflare/CVE-2022-31605.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:27 +0000.