Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Nuitka
  4. ›
  5. CVE-2022-2054

CVE-2022-2054: Command Injection in Nuitka

June 13, 2022 (updated September 26, 2024)

Nuitka 0.8.4 and prior is vulnerable to command injection. A patch is available and anticipated to be part of the 0.9 release.

References

  • github.com/Nuitka/Nuitka/commit/1765ffce2a9ab859853210337390de242cd80712
  • github.com/advisories/GHSA-4v3r-hqr9-69jf
  • github.com/nuitka/nuitka
  • github.com/nuitka/nuitka/commit/09647745d7cbb6ff32f9fa948f19d5558b32bcad
  • github.com/pypa/advisory-database/tree/main/vulns/nuitka/PYSEC-2022-209.yaml
  • huntr.dev/bounties/ea4a842c-c48c-4aae-a599-3305125c63a7
  • nvd.nist.gov/vuln/detail/CVE-2022-2054

Code Behaviors & Features

Detect and mitigate CVE-2022-2054 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.9

Fixed versions

  • 0.9

Solution

Upgrade to version 0.9 or above.

Impact 7.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')
  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/Nuitka/CVE-2022-2054.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:24 +0000.