Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. nltk
  4. ›
  5. CVE-2024-39705

CVE-2024-39705: ntlk unsafe deserialization vulnerability

June 28, 2024 (updated January 21, 2025)

NLTK through 3.8.1 allows remote code execution if untrusted packages have pickled Python code, and the integrated data package download functionality is used. This affects, for example, averaged_perceptron_tagger and punkt.

References

  • github.com/advisories/GHSA-cgvx-9447-vcch
  • github.com/nltk/nltk
  • github.com/nltk/nltk/commit/441aecb7d33014bd08672232c6c8bb69c2ceaba2
  • github.com/nltk/nltk/issues/2522
  • github.com/nltk/nltk/issues/3266
  • github.com/pypa/advisory-database/tree/main/vulns/nltk/PYSEC-2024-167.yaml
  • nvd.nist.gov/vuln/detail/CVE-2024-39705
  • www.vicarius.io/vsociety/posts/rce-in-python-nltk-cve-2024-39705-39706

Code Behaviors & Features

Detect and mitigate CVE-2024-39705 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.9

Fixed versions

  • 3.9

Solution

Upgrade to version 3.9 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-300: Channel Accessible by Non-Endpoint
  • CWE-502: Deserialization of Untrusted Data

Source file

pypi/nltk/CVE-2024-39705.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:30 +0000.