Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. nltk
  4. ›
  5. CVE-2019-14751

CVE-2019-14751: NLTK Vulnerable To Path Traversal

August 23, 2019 (updated October 7, 2024)

NLTK Downloader before 3.4.5 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in an NLTK package (ZIP archive) that is mishandled during extraction.

References

  • github.com/advisories/GHSA-mr7p-25v2-35wr
  • github.com/mssalvatore/CVE-2019-14751_PoC
  • github.com/nltk/nltk
  • github.com/nltk/nltk/blob/3.4.5/ChangeLog
  • github.com/nltk/nltk/commit/f59d7ed8df2e0e957f7f247fe218032abdbe9a10
  • github.com/pypa/advisory-database/tree/main/vulns/nltk/PYSEC-2019-106.yaml
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QI4IJGLZQ5S7C5LNRNROHAO2P526XE3D
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZGZSSEJH7RHH3RBUEVWWYT75QU67J7SE
  • nvd.nist.gov/vuln/detail/CVE-2019-14751
  • salvatoresecurity.com/zip-slip-in-nltk-cve-2019-14751

Code Behaviors & Features

Detect and mitigate CVE-2019-14751 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.4.5

Fixed versions

  • 3.4.5

Solution

Upgrade to version 3.4.5 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

pypi/nltk/CVE-2019-14751.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:14 +0000.