Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. nicegui
  4. ›
  5. CVE-2026-21873

CVE-2026-21873: NiceGUI apps which use `ui.sub_pages` vulnerable to zero-click XSS

January 8, 2026

An unsafe implementation in the pushstate event listener used by ui.sub_pages allows an attacker to manipulate the fragment identifier of the URL, which they can do despite being cross-site, using an iframe.

References

  • github.com/advisories/GHSA-mhpg-c27v-6mxr
  • github.com/zauberzeug/nicegui
  • github.com/zauberzeug/nicegui/releases/tag/v3.5.0
  • github.com/zauberzeug/nicegui/security/advisories/GHSA-mhpg-c27v-6mxr
  • nvd.nist.gov/vuln/detail/CVE-2026-21873

Code Behaviors & Features

Detect and mitigate CVE-2026-21873 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.22.0 before 3.5.0

Fixed versions

  • 3.5.0

Solution

Upgrade to version 3.5.0 or above.

Impact 7.2 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/nicegui/CVE-2026-21873.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:20 +0000.