Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. nbdime
  4. ›
  5. CVE-2021-41134

CVE-2021-41134: Stored XSS in Jupyter nbdime

November 8, 2021 (updated October 1, 2024)

Improper handling of user controlled input caused a stored cross-site scripting (XSS) vulnerability. All previous versions of nbdime are affected.

References

  • github.com/advisories/GHSA-p6rw-44q7-3fw4
  • github.com/jupyter/nbdime
  • github.com/jupyter/nbdime/commit/e44a5cc7677f24b45ebafc756db49058c2f750ea
  • github.com/jupyter/nbdime/security/advisories/GHSA-p6rw-44q7-3fw4
  • github.com/pypa/advisory-database/tree/main/vulns/nbdime/PYSEC-2021-428.yaml
  • nvd.nist.gov/vuln/detail/CVE-2021-41134

Code Behaviors & Features

Detect and mitigate CVE-2021-41134 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.1, all versions starting from 2.0.0 before 2.1.1, all versions starting from 3.0.0 before 3.1.1

Fixed versions

  • 1.1.1
  • 2.1.1
  • 3.1.1

Solution

Upgrade to versions 1.1.1, 2.1.1, 3.1.1 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/nbdime/CVE-2021-41134.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:17 +0000.