Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mxnet
  4. ›
  5. CVE-2022-24294

CVE-2022-24294: Apache MXNet vulnerable to potential denial-of-service by excessive resource consumption

July 25, 2022 (updated March 1, 2023)

A regular expression used in Apache MXNet (incubating) is vulnerable to a potential denial-of-service by excessive resource consumption. The bug could be exploited when loading a model in Apache MXNet that has a specially crafted operator name that would cause the regular expression evaluation to use excessive resources to attempt a match. This issue affects Apache MXNet versions prior to 1.9.1.

References

  • www.openwall.com/lists/oss-security/2022/07/24/2
  • github.com/advisories/GHSA-xxj3-55p6-xg3h
  • github.com/apache/mxnet/releases/tag/1.9.1
  • lists.apache.org/thread/b1fbfmvzlr2bbp95lqoh3mtovclfcl3o
  • nvd.nist.gov/vuln/detail/CVE-2022-24294

Code Behaviors & Features

Detect and mitigate CVE-2022-24294 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.9.1

Fixed versions

  • 1.9.1

Solution

Upgrade to version 1.9.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Source file

pypi/mxnet/CVE-2022-24294.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:49 +0000.