Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. motioneye
  4. ›
  5. CVE-2022-25568

CVE-2022-25568: MotionEye allows attackers to access sensitive information

March 25, 2022 (updated November 22, 2024)

MotionEye v0.42.1 and below allows attackers to access sensitive information via a GET request to /config/list. To exploit this vulnerability, a regular user password must be unconfigured.

References

  • github.com/advisories/GHSA-2c7w-v459-cwgf
  • github.com/ccrisan/motioneye/issues/2292
  • github.com/motioneye-project/motioneye
  • github.com/motioneye-project/motioneye/commit/c60b64af5bb8c09189071522a1f6796cb44340b0
  • github.com/pypa/advisory-database/tree/main/vulns/motioneye/PYSEC-2022-43141.yaml
  • nvd.nist.gov/vuln/detail/CVE-2022-25568
  • www.pizzapower.me/2022/02/17/motioneye-config-info-disclosure

Code Behaviors & Features

Detect and mitigate CVE-2022-25568 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.43.1b1

Fixed versions

  • 0.43.1b1

Solution

Upgrade to version 0.43.1b1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

pypi/motioneye/CVE-2022-25568.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:38 +0000.