Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. moin
  4. ›
  5. CVE-2016-9119

CVE-2016-9119: MoinMoin Cross-site Scripting (XSS) vulnerability

May 17, 2022 (updated September 26, 2024)

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

References

  • github.com/advisories/GHSA-5fq5-pfv8-mrfv
  • github.com/moinwiki/moin
  • github.com/pypa/advisory-database/tree/main/vulns/moin/PYSEC-2017-20.yaml
  • moinmo.in/SecurityFixes
  • nvd.nist.gov/vuln/detail/CVE-2016-9119
  • web.archive.org/web/20200227212253/http://www.securityfocus.com/bid/94501

Code Behaviors & Features

Detect and mitigate CVE-2016-9119 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.9.8

Fixed versions

  • 1.9.8

Solution

Upgrade to version 1.9.8 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/moin/CVE-2016-9119.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:00 +0000.