Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. moin
  4. ›
  5. CVE-2016-7148

CVE-2016-7148: MoinMoin Cross-site Scripting (XSS) vulnerability

May 17, 2022 (updated October 1, 2024)

MoinMoin 1.9.8 allows remote attackers to conduct “JavaScript injection” attacks by using the “page creation” approach, related to a “Cross Site Scripting (XSS)” issue affecting the action=AttachFile (via page name) component.

References

  • github.com/advisories/GHSA-3x76-j3jj-439j
  • github.com/moinwiki/moin
  • github.com/pypa/advisory-database/tree/main/vulns/moin/PYSEC-2016-31.yaml
  • nvd.nist.gov/vuln/detail/CVE-2016-7148
  • web.archive.org/web/20200227212542/http://www.securityfocus.com/bid/94259
  • web.archive.org/web/20230601130846/https://www.curesec.com/blog/article/blog/MoinMoin-198-XSS-175.html
  • www.debian.org/security/2016/dsa-3715
  • www.ubuntu.com/usn/USN-3137-1

Code Behaviors & Features

Detect and mitigate CVE-2016-7148 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.9.9

Fixed versions

  • 1.9.9

Solution

Upgrade to version 1.9.9 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/moin/CVE-2016-7148.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:19 +0000.