Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. modoboa
  4. ›
  5. CVE-2023-2160

CVE-2023-2160: Modoboa has Weak Password Requirements

April 18, 2023 (updated September 30, 2024)

Modoboa 2.0.5 and prior allows users to set unsafe passwords, such as 1 or HACK. This issue is fixed in commit 130257c96a2392ada795785a91178e656e27015c and is part of version 2.1.0.

References

  • github.com/advisories/GHSA-9gxx-32p7-ff7m
  • github.com/modoboa/modoboa
  • github.com/modoboa/modoboa/commit/130257c96a2392ada795785a91178e656e27015c
  • github.com/pypa/advisory-database/tree/main/vulns/modoboa/PYSEC-2023-34.yaml
  • huntr.dev/bounties/54fb6d6a-6b39-45b6-b62a-930260ba484b
  • nvd.nist.gov/vuln/detail/CVE-2023-2160

Code Behaviors & Features

Detect and mitigate CVE-2023-2160 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.0

Fixed versions

  • 2.1.0

Solution

Upgrade to version 2.1.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-521: Weak Password Requirements

Source file

pypi/modoboa/CVE-2023-2160.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:52 +0000.