Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mod-wsgi
  4. ›
  5. CVE-2022-2255

CVE-2022-2255: Incorrect header handling in mod-wsgi

August 26, 2022 (updated September 25, 2024)

A vulnerability was found in mod_wsgi. The X-Client-IP header is not removed from a request from an untrusted proxy, allowing an attacker to pass the X-Client-IP header to the target WSGI application because the condition to remove it is missing.

References

  • github.com/GrahamDumpleton/mod_wsgi
  • github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c
  • github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c
  • github.com/GrahamDumpleton/mod_wsgi/commit/af3c0c2736bc0b0b01fa0f0aad3c904b7fa9c751
  • github.com/advisories/GHSA-7527-8855-9cf8
  • github.com/pypa/advisory-database/tree/main/vulns/mod-wsgi/PYSEC-2022-254.yaml
  • lists.debian.org/debian-lts-announce/2022/09/msg00021.html
  • modwsgi.readthedocs.io/en/latest/release-notes/version-4.9.3.html
  • nvd.nist.gov/vuln/detail/CVE-2022-2255

Code Behaviors & Features

Detect and mitigate CVE-2022-2255 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.9.3

Fixed versions

  • 4.9.3

Solution

Upgrade to version 4.9.3 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-345: Insufficient Verification of Data Authenticity

Source file

pypi/mod-wsgi/CVE-2022-2255.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:44 +0000.