Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mlflow
  4. ›
  5. CVE-2023-2780

CVE-2023-2780: mlflow Path Traversal vulnerability

May 17, 2023 (updated September 24, 2024)

mlflow prior to 2.3.0 is vulnerable to path traversal due to a bypass of the fix for CVE-2023-1177.

References

  • github.com/advisories/GHSA-wjq3-7jxx-whj9
  • github.com/mlflow/mlflow
  • github.com/mlflow/mlflow/commit/fae77a525dd908c56d6204a4cef1c1c75b4e9857
  • github.com/pypa/advisory-database/tree/main/vulns/mlflow/PYSEC-2023-69.yaml
  • huntr.dev/bounties/b12b0073-0bb0-4bd1-8fc2-ec7f17fd7689
  • nvd.nist.gov/vuln/detail/CVE-2023-2780

Code Behaviors & Features

Detect and mitigate CVE-2023-2780 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.0

Fixed versions

  • 2.3.0

Solution

Upgrade to version 2.3.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-29: Path Traversal: '..filename'

Source file

pypi/mlflow/CVE-2023-2780.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.