Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mlalchemy
  4. ›
  5. CVE-2017-16615

CVE-2017-16615: Unsafe deserialization in MLAlchemy

July 13, 2018 (updated September 24, 2024)

An exploitable vulnerability exists in the YAML parsing functionality in the parse_yaml_query method in parser.py in MLAlchemy before 0.2.2. When processing YAML-Based queries for data, a YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.

References

  • github.com/advisories/GHSA-xpm8-98mx-h4c5
  • github.com/pypa/advisory-database/tree/main/vulns/mlalchemy/PYSEC-2017-19.yaml
  • github.com/thanethomson/MLAlchemy
  • github.com/thanethomson/MLAlchemy/commit/bc795757febdcce430d89f9d08f75c32d6989d3c
  • github.com/thanethomson/MLAlchemy/issues/1
  • joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16615-critical-restful-web-applications-vulnerability
  • nvd.nist.gov/vuln/detail/CVE-2017-16615

Code Behaviors & Features

Detect and mitigate CVE-2017-16615 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.2.2

Fixed versions

  • 0.2.2

Solution

Upgrade to version 0.2.2 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

pypi/mlalchemy/CVE-2017-16615.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.