Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mkdocs-include-markdown-plugin
  4. ›
  5. CVE-2025-59940

CVE-2025-59940: mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders

September 29, 2025 (updated September 30, 2025)

CWE-20: Improper Input Validation Low impact

References

  • github.com/advisories/GHSA-v39m-5m9j-m9w9
  • github.com/mondeja/mkdocs-include-markdown-plugin
  • github.com/mondeja/mkdocs-include-markdown-plugin/commit/7466d67aa0de8ffbc427204ad2475fed07678915
  • github.com/mondeja/mkdocs-include-markdown-plugin/issues/274
  • github.com/mondeja/mkdocs-include-markdown-plugin/pull/277
  • github.com/mondeja/mkdocs-include-markdown-plugin/security/advisories/GHSA-v39m-5m9j-m9w9
  • nvd.nist.gov/vuln/detail/CVE-2025-59940

Code Behaviors & Features

Detect and mitigate CVE-2025-59940 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 7.1.8

Fixed versions

  • 7.1.8

Solution

Upgrade to version 7.1.8 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/mkdocs-include-markdown-plugin/CVE-2025-59940.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:18 +0000.