Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mercurial
  4. ›
  5. CVE-2018-1000132

CVE-2018-1000132: Mercurial Incorrect Access Control vulnerability

May 13, 2022 (updated September 24, 2024)

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

References

  • access.redhat.com/errata/RHSA-2019:2276
  • github.com/advisories/GHSA-4mr4-7vjv-9hm6
  • github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2018-87.yaml
  • lists.debian.org/debian-lts-announce/2018/03/msg00034.html
  • lists.debian.org/debian-lts-announce/2018/07/msg00005.html
  • lists.debian.org/debian-lts-announce/2020/07/msg00032.html
  • nvd.nist.gov/vuln/detail/CVE-2018-1000132
  • www.mercurial-scm.org/wiki/WhatsNew

Code Behaviors & Features

Detect and mitigate CVE-2018-1000132 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.5.1

Fixed versions

  • 4.5.1

Solution

Upgrade to version 4.5.1 or above.

Impact 9.1 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-732: Incorrect Permission Assignment for Critical Resource

Source file

pypi/mercurial/CVE-2018-1000132.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:21 +0000.