Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mercurial
  4. ›
  5. CVE-2016-3630

CVE-2016-3630: Mercurial arbitrary code execution vulnerability

May 14, 2022 (updated September 24, 2024)

The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.

References

  • github.com/advisories/GHSA-9vjf-jjcq-3gh7
  • github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2016-29.yaml
  • nvd.nist.gov/vuln/detail/CVE-2016-3630
  • security.gentoo.org/glsa/201612-19
  • selenic.com/repo/hg-stable/rev/b6ed2505d6cf
  • selenic.com/repo/hg-stable/rev/b9714d958e89
  • www.mercurial-scm.org/wiki/WhatsNew

Code Behaviors & Features

Detect and mitigate CVE-2016-3630 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.7.3

Fixed versions

  • 3.7.3

Solution

Upgrade to version 3.7.3 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

pypi/mercurial/CVE-2016-3630.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.