Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mercurial
  4. ›
  5. CVE-2016-3105

CVE-2016-3105: Mercurial vulnerable to arbitrary code execution when converting Git repos

May 17, 2022 (updated September 30, 2024)

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

References

  • github.com/advisories/GHSA-49cw-434h-qc57
  • github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2016-28.yaml
  • nvd.nist.gov/vuln/detail/CVE-2016-3105
  • security.gentoo.org/glsa/201612-19
  • selenic.com/hg/rev/a56296f55a5e
  • web.archive.org/web/20200228012056/http://www.securityfocus.com/bid/90536
  • www.mercurial-scm.org/wiki/WhatsNew

Code Behaviors & Features

Detect and mitigate CVE-2016-3105 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.8

Fixed versions

  • 3.8

Solution

Upgrade to version 3.8 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control

Source file

pypi/mercurial/CVE-2016-3105.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:26 +0000.