Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. mem0ai
  4. ›
  5. CVE-2026-7597

CVE-2026-7597: mem0ai mem0 has an Improper Input Validation Issue

May 2, 2026 (updated May 7, 2026)

A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vector_stores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.

References

  • github.com/advisories/GHSA-xqxw-r767-67m7
  • github.com/mem0ai/mem0
  • github.com/mem0ai/mem0/commit/62dca096f9236010ca15fea9ba369ba740b86b7a
  • github.com/mem0ai/mem0/issues/3778
  • github.com/mem0ai/mem0/pull/4833
  • nvd.nist.gov/vuln/detail/CVE-2026-7597
  • vuldb.com/submit/805562
  • vuldb.com/vuln/360550
  • vuldb.com/vuln/360550/cti

Code Behaviors & Features

Detect and mitigate CVE-2026-7597 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.0.0-b.2

Fixed versions

  • 2.0.0-b.2

Solution

Upgrade to version 2.0.0-b.2 or above.

Impact 6.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/mem0ai/CVE-2026-7597.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:26 +0000.