Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. llama-index
  4. ›
  5. CVE-2025-1752

CVE-2025-1752: LlamaIndex Vulnerable to Denial of Service (DoS)

May 10, 2025 (updated October 15, 2025)

A Denial of Service (DoS) vulnerability has been identified in the KnowledgeBaseWebReader class of the run-llama/llama_index project, affecting version ~ latest(v0.12.15). The vulnerability arises due to inappropriate secure coding measures, specifically the lack of proper implementation of the max_depth parameter in the get_article_urls function. This allows an attacker to exhaust Python’s recursion limit through repeated function calls, leading to resource consumption and ultimately crashing the Python process.

References

  • github.com/advisories/GHSA-7c85-87cp-mr6g
  • github.com/run-llama/llama_index
  • github.com/run-llama/llama_index/commit/3c65db2947271de3bd1927dc66a044da385de4da
  • huntr.com/bounties/cd7b9082-7d75-42e4-84f5-dbee23cbc467
  • nvd.nist.gov/vuln/detail/CVE-2025-1752

Code Behaviors & Features

Detect and mitigate CVE-2025-1752 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.12.15 before 0.12.21

Fixed versions

  • 0.12.21

Solution

Upgrade to version 0.12.21 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption
  • CWE-674: Uncontrolled Recursion

Source file

pypi/llama-index/CVE-2025-1752.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.