Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. llama-index
  4. ›
  5. CVE-2024-4181

CVE-2024-4181: RunGptLLM class in LlamaIndex has a command injection

May 16, 2024

A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client’s machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.

References

  • github.com/advisories/GHSA-pw38-xv9x-h8ch
  • github.com/run-llama/llama_index
  • github.com/run-llama/llama_index/commit/d73715eaf0642705583e7897c78b9c8dd2d3a7ba
  • huntr.com/bounties/1a204520-598a-434e-b13d-0d34f2a5ddc1
  • nvd.nist.gov/vuln/detail/CVE-2024-4181

Code Behaviors & Features

Detect and mitigate CVE-2024-4181 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.10.13

Fixed versions

  • 0.10.13

Solution

Upgrade to version 0.10.13 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/llama-index/CVE-2024-4181.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:49 +0000.