Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. litellm
  4. ›
  5. CVE-2026-47102

CVE-2026-47102: LiteLLM allows a user to modify their own user_role via the /user/update endpoint

May 21, 2026 (updated June 23, 2026)

LiteLLM prior to 1.83.10 allows a user to modify their own user_role via the /user/update endpoint. While the endpoint correctly restricts users to updating only their own account, it does not restrict which fields may be changed. A user who can reach this endpoint can set their role to proxy_admin, gaining full administrative access to LiteLLM including all users, teams, keys, models, and prompt history. Users with the org_admin role have legitimate access to this endpoint and can exploit this vulnerability without chaining any additional flaw.

References

  • gist.github.com/13ph03nix/9ec616e1fdc77b3673509c60206e827f
  • github.com/BerriAI/litellm/commit/128d32d2494b759c5d15da3452452af4c6a34c01
  • github.com/BerriAI/litellm/commit/e6f18ce75b111c9b93dc15c72894cbdeb53177ce
  • github.com/BerriAI/litellm/pull/25541
  • github.com/BerriAI/litellm/releases/tag/v1.83.10-stable
  • github.com/advisories/GHSA-wpfp-gwwc-vwq6
  • huntr.com/bounties/8e75edfb-ff05-4e63-bfca-2d93d03fb3b9
  • nvd.nist.gov/vuln/detail/CVE-2026-47102
  • www.obsidiansecurity.com/blog/litellm-privilege-escalation-rce
  • www.vulncheck.com/advisories/litellm-privilege-escalation-via-user-update

Code Behaviors & Features

Detect and mitigate CVE-2026-47102 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.83.10

Fixed versions

  • 1.83.10

Solution

Upgrade to version 1.83.10 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

pypi/litellm/CVE-2026-47102.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:34 +0000.