Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. litellm
  4. ›
  5. CVE-2026-35029

CVE-2026-35029: LiteLLM: Privilege escalation via unrestricted proxy configuration endpoint

April 3, 2026 (updated May 6, 2026)

The /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to do the following:

  • Modify proxy configuration and environment variables
  • Register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution
  • Read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image
  • Take over other priveleged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables

References

  • github.com/BerriAI/litellm/security/advisories/GHSA-53mr-6c8q-9789
  • github.com/advisories/GHSA-53mr-6c8q-9789
  • nvd.nist.gov/vuln/detail/CVE-2026-35029

Code Behaviors & Features

Detect and mitigate CVE-2026-35029 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.83.0

Fixed versions

  • 1.83.0

Solution

Upgrade to version 1.83.0 or above.

Impact 9.9 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

pypi/litellm/CVE-2026-35029.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:58 +0000.