Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. litellm
  4. ›
  5. CVE-2024-5751

CVE-2024-5751: litellm vulnerable to remote code exection base on using eval unsafely

June 27, 2024 (updated June 28, 2024)

BerriAI/litellm version v1.35.8 contains a vulnerability where an attacker can achieve remote code execution. The vulnerability exists in the add_deployment function, which decodes and decrypts environment variables from base64 and assigns them to os.environ. An attacker can exploit this by sending a malicious payload to the /config/update endpoint, which is then processed and executed by the server when the get_secret function is triggered. This requires the server to use Google KMS and a database to store a model.

References

  • github.com/BerriAI/litellm/commit/fcea4c22ad96b24436f196ae709f71932e84b0b8
  • github.com/BerriAI/litellm/pull/4228
  • github.com/advisories/GHSA-gppg-gqw8-wh9g
  • github.com/berriai/litellm
  • huntr.com/bounties/ae623c2f-b64b-4245-9ed4-f13a0a5824ce
  • nvd.nist.gov/vuln/detail/CVE-2024-5751

Code Behaviors & Features

Detect and mitigate CVE-2024-5751 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.40.16

Fixed versions

  • 1.40.16

Solution

Upgrade to version 1.40.16 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/litellm/CVE-2024-5751.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:22 +0000.