Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. litellm
  4. ›
  5. CVE-2024-10188

CVE-2024-10188: LiteLLM Vulnerable to Denial of Service (DoS)

March 20, 2025

A vulnerability in BerriAI/litellm, as of commit 26c03c9, allows unauthenticated users to cause a Denial of Service (DoS) by exploiting the use of ast.literal_eval to parse user input. This function is not safe and is prone to DoS attacks, which can crash the litellm Python server.

References

  • github.com/BerriAI/litellm
  • github.com/advisories/GHSA-gw2q-qw9j-rgv7
  • github.com/berriai/litellm/commit/21156ff5d0d84a7dd93f951ca033275c77e4f73c
  • huntr.com/bounties/96a32812-213c-4819-ba4e-36143d35e95b
  • nvd.nist.gov/vuln/detail/CVE-2024-10188

Code Behaviors & Features

Detect and mitigate CVE-2024-10188 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.53.1.dev1

Fixed versions

  • 1.53.1.dev1

Solution

Upgrade to version 1.53.1.dev1 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption

Source file

pypi/litellm/CVE-2024-10188.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.