Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. leo
  4. ›
  5. CVE-2020-23478

CVE-2020-23478: Regular Expression Denial of Service in Leo Editor

September 23, 2021 (updated September 27, 2024)

Leo Editor v6.2.1 was discovered to contain a regular expression denial of service (ReDoS) vulnerability in the component plugins/importers/dart.py.

References

  • github.com/advisories/GHSA-x38q-xg2h-rxgx
  • github.com/leo-editor/leo-editor
  • github.com/leo-editor/leo-editor/commit/029833689060ee73f1bc1708cf4b182f0c66ec8e
  • github.com/leo-editor/leo-editor/issues/1597
  • github.com/pypa/advisory-database/tree/main/vulns/leo/PYSEC-2021-338.yaml
  • nvd.nist.gov/vuln/detail/CVE-2020-23478

Code Behaviors & Features

Detect and mitigate CVE-2020-23478 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 6.3

Fixed versions

  • 6.3

Solution

Upgrade to version 6.3 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-1333: Inefficient Regular Expression Complexity
  • CWE-697: Incorrect Comparison

Source file

pypi/leo/CVE-2020-23478.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:16 +0000.