Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. langflow
  4. ›
  5. GHSA-c995-4fw3-j39m

GHSA-c995-4fw3-j39m: Duplicate Advisory: Langflow Vulnerable to Code Injection via the `/api/v1/validate/code` endpoint

April 7, 2025 (updated June 17, 2025)

Duplicate Advisory

This advisory has been withdrawn because it is a duplicate of GHSA-rvqx-wpfh-mfx7. This link is maintained to preserve external references.

Original Description

Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.

References

  • github.com/advisories/GHSA-c995-4fw3-j39m
  • github.com/langflow-ai/langflow
  • github.com/langflow-ai/langflow/pull/6911
  • github.com/langflow-ai/langflow/releases/tag/1.3.0
  • nvd.nist.gov/vuln/detail/CVE-2025-3248
  • www.horizon3.ai/attack-research/disclosures/unsafe-at-any-speed-abusing-python-exec-for-unauth-rce-in-langflow-ai

Code Behaviors & Features

Detect and mitigate GHSA-c995-4fw3-j39m with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.0

Fixed versions

  • 1.3.0

Solution

Upgrade to version 1.3.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-306: Missing Authentication for Critical Function
  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/langflow/GHSA-c995-4fw3-j39m.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:17 +0000.